Low

JOHANSON MANUFACTURING  RF800BA14-004  RESISTOR THICK FILM FLANGED, 100 OHM

Image is for illustrative purposes only. Please refer to product description.

Product Information


  • Frequency Max: 6GHz
  • MSL: -
  • Operating Temperature Max: 100°C
  • Operating Temperature Min: -55°C
  • Power Rating: 800W
  • Resistance: 100ohm
  • Resistance Tolerance: ± 5%
  • Resistor Case Style: -
  • Resistor Mounting: Panel
  • SVHC: No SVHC (16-Jun-2014)
  • Temperature Coefficient: ± 100ppm/°C

Find similar products  grouped by common attribute

View this product in our online catalog


This product also features on the following pages and catalog editions:

  •  129/525
  •  130/527

Availability

Availability:  142


  • 142 in stock for same day shipping
 
Check stock and lead times
    Per the manufacturer, more stock expected week of 12/1/14

Price for: Each 1

Minimum order quantity: 1

Order multiple quantity: 1

Price: $62.94

Buy

Price

Quantity List Price
1 - 24 $62.94
25 - 49 $56.78
50 - 99 $49.23
100 - 249 $46.15
250+ $42.52

Legislation and Environmental


Back to top

Similar Products


Find products functionally similar to this one. Select one of the following links, and you will be taken to a product group page that presents all products in this category that share the given attribute.

Back to top

Customer Reviews


Customer Q&A Exchange


(There is 1 question : 1 answer on this product)

Product Q&A

Ask your questions. Share your answers.

 
 
Browse Q&A
 
 
Search Questions
Need Product Support?
If you need immediate technical support use Live Support or Contact Us.
This space is yours...
Use this space to Ask your peers product questions or Answer those questions posted by them.
Details: 
Afte a short period of operation at @250 watts rf at 1.49mhz swr starts to rise and I find the resistance value has started to increase, after removing power it drops back down to 50 ohms, shouldn't it be capable of running quite awhile at that power level or am I using wrong part?. thanks Michael
2 years, 9 months ago
by
MichaelC
0points
0out of 0found this question helpful.
Was this helpful?(0)(0)

Answers

A: 
As per specs this should be working. Please check your circuitry and do share with us the same for further suggestion.
2 years, 8 months ago
by
TechGTC
0points
0out of 0found this answer helpful.
Was this helpful?(0)(0)
1 of 1
1 of 1
Back to top

Community


Like to see information about this product from other customers?

 Read discussions, blogs, documents from our community members.

Filters:

Post a question to one of our experts or start a discussion and get responses from supplier experts and fellow engineers in our community.
Back to top

Associated Products


Customers Also Bought